clientaccesspolicy.xml not found by the server

Aug 24, 2010 at 6:28 PM

Hello,

Even though the file is at the root level the file is not being found when I run the project. I know is at the root level because when I run a web traffic sniffer it does shows the file at the root but with error code 404.

The exact error is:

Communication exception occurred.

An error occurred while trying to make a request to URI ‘http://localhost/HappyNet/Services/loggingServices.svc’. This could be due to attempting to access a service in a cross-domain way without a proper cross-domain policy in place, or a policy that is unsuitable for SOAP services. You may need to contact the owner of the service to publish a cross-domain policy file and to ensure it allows SOAP-related HTTP headers to be sent.

Am I missing something?

Thanks in advance.

Coordinator
Aug 27, 2010 at 9:35 AM

Hey,

If you're running your app as localhost (say http://localhost/HappyNet), there's no need for a clientaccesspolicy.xml.
You can add one at the root level, just to be sure, but the problem must come from elsewhere.

Have you tried running the service in your browser, through the url http://localhost/HappyNet/Services/loggingServices.svc ?

Cyril

Apr 1, 2011 at 5:19 PM

Hey,

Try to copy clientaccesspolicy.xmlcrossdomain.xml files to the "inetpub\wwwroot" folder.